Database issues in the Dallas TX datacenter

Incident Report for Wikimedia

Resolved

Traffic back to baseline, root cause investigation is still ongoing but the incident is resolved.
Posted Oct 24, 2024 - 14:02 UTC

Update

We are continuing to monitor for any further issues.
Posted Oct 24, 2024 - 13:52 UTC

Monitoring

We have repooled the primary datacenter for read traffic and are monitoring the situation while investigating the root cause.
Posted Oct 24, 2024 - 13:49 UTC

Update

We shifted read traffic to the secondary datacenter, which helped with the overloaded database. We are still investigating the root cause.
Posted Oct 24, 2024 - 11:33 UTC

Investigating

Reading and editing is affected. We are investigating the issue.
Posted Oct 24, 2024 - 11:02 UTC
This incident affected: Reading and Editing.